Only RAFT adhesion method is functioning


I stepped away from 3d printing projects for a while. Last week I had some things I wanted build up. I was prompted that the software was out of date, so I went ahead and did that. Now, I have found that only raft adhesion is successful for me now. I’ve tried all the normal tricks, up to tape/glue. I have never had any problems with brim (or even skirt!) in the past. Is this some issue the new stable release?


Ok. So. I notice now that it actually installed a different program! I will uninstall snapmaker3d and try with this snapmakerjs.


I recalibrated, but the recommended settings still did the same thing. However, there are now ways to increase the first layer height, so I made it .4 and that seemed to be work.


Glad to know that your problem was fixed. Please don’t hesitate to tell us if you have any problem.


I was having a lot of trouble getting good adhesion using the default calibration method. I ended up printing a large flat square, and tweaking the calibration based on that.

I’ve also had problems getting good adhesion if I haven’t printed recently. I eventually noticed that even a small amount of dust on the bed would cause a lot of problems. I don’t have the enclosure, so I created a small paper cover to keep on the bed when I’m not using it. That’s helped a lot.


New to the Forum and new machine. Love it so far but something has gone wrong yesterday. I had ver-2.4 (New machine) and started printing a test part and it got 5-6 layers up and it separated from the base. Did this 3-4 times so I updated to Ver-2.9 latest and latest JS and nothing is working now. It’s not attaching at all. I’m back on it tonight to revert back to the original revisions and see if it works again and then try different settings to get it to stick better. Also slowing down and I’ll try RAFT tonight also.

Currently it tries to print but does nothing but wads up the material around the nozzle. Have tried moving the calibration up/down 1 step at a time .05mm. (have gone +6 steps and -6 steps and still no change. Have redone the calibration so many times it’s painful. Have read up and tried many of the steps.

I’m thinking the current version for the CPU and JS has an issue but I cannot put my finger on it.

Printing with the supplied PLA with the following settings. JS for GCODE
Have tried both Fast and Normal printing.
First Layer 200C, Next layers 198C
Table first Layer 65C, Next layers 60c (Have tried 50/50C, 55/50C & 55/60C also). Cleaned with Alcohol. (Will try the tape method next).
With & Without Raft/Brim (Tried both).

Will try The test square to check calibration heights and adhesion. Also try some custom settings to slow down the first pass and height. (10mm/s and .4mm height).

Anyone else having similar issues with this new version?


I regularly use glue stick on the bed. It’s messy and requires a good cleaning after a few prints, but It guarantees me a good adhesion and since I’ve been using the printer with this technique I’ve never had a problem.

I generally use skirt and if the part has a small base I’ll use a Brim - never used a raft 'til now. I generally print with the standard presets Normal or even Fast Print settings. Sometimes I’ll customize for wall thickness or infill etc.

Also, I always print from USB Drive, never from PC/Laptop.


I have always avoided using glue sticks or hair spray though I hear they work well. I may have to try them one of these days if benchy doesn’t make it through. So far, I’ve managed to find software fixes for a hardware problems.


I slowed down to 10mm/s and lowered temperature of bed to 55C, and I’ve scrubbed it with 99% iso several times. Something, somewhere in there helped. I was able to lower the 0.4mm initial layer back down to 0.3mm. I think the speed will be a change I incorporate in all but the most basic designs. Sometimes things just feel right, and watching the first layer lay at 10mm was zen for me.


Victory I got it printing every time…

What changed…

So latest version is working better and I tried something from my CNC experience…

I used a 1/2/3 block and lowered the x axis down onto the 1/2/3 block on the table. Loosened the screws and then leveled the x-axis on top of the 1/2/3 block and then tightened the screws. Then leveled the table with paper and wow. Every time it works…!!!

I think the self leveling does an ok job but having the axis level to the table has made it a hell of a lot better.

I also scrub the surface with alcohol during warm up and clean the nozzle. Slowing down the first layer helped a lot.

So I’m a printing everything and soon will be trying other materials… ABS and others…


i CAN NOT get prints to stick. I have a prusa, ender 3, ender 3 pro, and nwa3d. I’m no noob. The best I could do was blue tape with a buttload of glue stick glue.
I just got a PEI sheet and plan on ripping off the build tak like surface and change to it (same stuff prusa uses). I pray this works.
@enlightenonq can you share a quick video of how you used the 1/2/3 block?


I try to get a picture of it…
But for now:
Center up the Y axis table under the X–axis cross and either remove or move the extruder to the far left.

Place the 1/2/3 block:
With the 3 holes down on the plate on the long axis under the x-axis. Use pad to lower the x-axis until it just about touches. Loosen screws and drop down a couple of steps press the x-axis down on the 1/2/3 block so it’s parallel to the plate. Keep pressure on the x-axis while you tighten the screws attaching it to the z-axis.

Check your level again using the paper method making sure to slide the paper with 1 finger and as you drop the “Z” as soon as the paper bunches up… STOP and move to the next point.